Vagrant: SSL Certificate Error when installing a plugin

If you’re installing a plugin using a proxy, then you may come across a problem where the proxy acts as a middle man and effectively invalidates the SSL certificate.

One way around this is to not use SSL at all when installing a Vagrant plugin. Unfortunately the vagrant plugin install command doesn’t (yet ?) support a “–insecure” option like when installing a box. Therefore we have to work around this. The best way I’ve found of doing this is telling the vagrant not to use https, but rather just http. This can be done as follows as an example:-

<br />vagrant plugin install &lt;plugin-name&gt; --plugin-source http://rubygems.org<br />

If you are looking at setting up Vagrant behind a corporate proxy then have a look at my other post.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.